How to put a "pixoto" watermark on your photo?

  • 1
  • Question
  • Updated 8 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Answered

Actually I forgot to checked the watermark button when i registered to stock photo. Now i want my photos with a pixoto watermark but i don't know how? help me please thanks!!!
Photo of Charlie


  • 636 Posts
  • 52 Reply Likes

Posted 8 years ago

  • 1
Photo of Justin Kifer

Justin Kifer, Official Rep

  • 949 Posts
  • 193 Reply Likes
Go to the Edit Settings link in the profile drop down at the top right of the site. Then scroll down to the blue Monetize section of the page and click the Edit Settings link to the right for Sell Stock Images. This will pop the Stock Contributor sign up overlay and you can check the Pixoto Watermark box and Save the form.

Let me know if you need any more assistance!
Photo of Charlie


  • 636 Posts
  • 52 Reply Likes
Thank you very much for attending my inquiry, i love this site so much. God bless to you all.
Photo of David Ubach

David Ubach

  • 46 Posts
  • 0 Reply Likes
i cant find the edit settings link
Photo of Sherry Andreason

Sherry Andreason

  • 4466 Posts
  • 218 Reply Likes
Hello David, hoover your mouse over your Profile picture at the top right of your screen, a menu will appear, go to My Account, in the middle of the screen you will see several Tabs, click on the Market tab, right above the payment info there is a check box for adding the watermark. Please note that the watermark is only available for images that have been added to the Marketplace.
Photo of Goran


  • 7 Posts
  • 0 Reply Likes
i have marked to put the pixoto watermark and only few of them have it? why?
Photo of Dipali


  • 1846 Posts
  • 94 Reply Likes
Only those images have watermark that you have marked to put in market for Stock and/or Canvas. We would like the watermark on all the images though.

This conversation is no longer open for comments or replies.