Language setting not working

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Because you don't mind your own business. You are displaying the wrong language.
Photo of Dave

Dave

  • 12 Posts
  • 7 Reply Likes

Posted 2 years ago

  • 1
Photo of Steve

Steve, Official Rep

  • 1807 Posts
  • 1425 Reply Likes
Please also include:

- the device you are using and the language of your device
- the OS version of this device
- the method you are using to access IMDb
- your physical location (zip/postal code)

Thanks in advance!
(Edited)
Photo of Steve

Steve, Official Rep

  • 1807 Posts
  • 1425 Reply Likes
Hi Dave,

We are a bit confused as to the issue you are experiencing. You mentioned that your language is set to English for Canada. What language are you seeing? What is the language you are expecting to see?
Please provide us with a screenshot of what you are seeing to clarify.
Thanks in advance! Appreciate your cooperation so we can investigate further.
Photo of MAthePA

MAthePA

  • 2079 Posts
  • 3522 Reply Likes
Hi, Dave.
Since the IMDb system for language preferences is actually not so direct and clear as we all might expect, I may suggest you some temporal workarounds to try.

First, in the "Site Preferences" of your profile try to change the "Title display country/region" into "United Kingdom" (don't forget the yellow "Submit" button), then re-open your watch-list. If this doesn't help, try "United States". If both variants don't help, make sure your Chrome Devices are not enrolled to a primary domain.

Second, if nothing above helps, try to set "Original" for the "Title display country/region". It may not be totally comfortable, but would be better as a temporary measure in your situation, if it works.