"Watch it" button hasn't worked on anything I've looked at in at least a month

  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
Why is the "Watch it" button broken? All it has done for weeks is give me this message: "We're sorry. We don't have any videos that match your search." Even when I search Amazon's videos and find the movie or TV show available in instant video, I still get this message on IMDB.
What's going on? Amazon owns IMDB. Why aren't the videos linked?
Photo of sed451

sed451

  • 13 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Michelle

Michelle, Official Rep

  • 12714 Posts
  • 9619 Reply Likes
Hi sed451 -

Can you clarify exactly what button you are referring to?  Are you clicking on the "Watch Trailer" button or the "Watch Now" link?

Can you give some examples of titles where this issue has occurred on?


Photo of sed451

sed451

  • 13 Posts
  • 1 Reply Like
Hi Michelle,
My screen (on Firefox) doesn't have either of those buttons. It has a yellow "Watch it" button, under which it says "at Amazon." I don't have IMDB Pro.

Maleficent worked, as did several other movies. The Boxtrolls had a greyed out button, and it is available on Amazon Instant Video.
Bones, Falling Skies, Under the Dome did not.
For Falling Skies, the page that came up was http://www.imdb.com/title/tt1462059/videogallery/content_type-Full%20Episode and it says, "We're sorry. We don't have any videos that match your search." Since I've watched this series on Amazon, I know that message is in error.
Photo of Michelle

Michelle, Official Rep

  • 12714 Posts
  • 9619 Reply Likes
Hi sed451 -

Apologies for the delay in replying.  I was able to replicate the issues you described when I accessed the old reference view site display, which I suspect is how you are accessing the site. 

We no longer support the 'reference' view , therefore, I encourage you to use the current display of the site going forward as this version is supported and up-to-date.
You can access your Site Preferences here, you will need to un-check the 'Show reference view (old title/name page layout)' box and click on the 'Update' button.

Once you have updated your site preferences, please check the title pages you mentioned and you should then be able to access the Video content.
(Edited)
Photo of sed451

sed451

  • 13 Posts
  • 1 Reply Like
Ah-Ha.
I know why I had that box for "old reference view" checked.
When you first switched to the "new" layout, I couldn't find the soundtracks from the musicals. It's there, now, nearly at the bottom below everything but the FAQs and User Reviews.
I hated the new layout initially. It appears to have been modified since its first appearance, though.
Thank you for figuring out the solution.
Photo of Michelle

Michelle, Official Rep

  • 12714 Posts
  • 9607 Reply Likes
You're Welcome!