[link=] contribution needs one more filter: for [Link=]

  • 3
  • Problem
  • Updated 9 months ago
  • In Progress
Apparently [Link=...] does not work:

But the Edit page does not screen for that. Here I've altered a working link to "L", and no protest from Check These Updates:


Either [Link=] should work as well as [link=], or [Link=] should get rejected during the Edit process.
Photo of bderoes

bderoes, Champion

  • 2239 Posts
  • 3700 Reply Likes

Posted 9 months ago

  • 3
Photo of bderoes

bderoes, Champion

  • 2239 Posts
  • 3700 Reply Likes
Similarly, (link=) does not work:

But when I change a working link to (link=), Check These Updates does not protest:


Same with curly braces {}.

(Edited)
Photo of bderoes

bderoes, Champion

  • 2239 Posts
  • 3700 Reply Likes
Other common mistakes to screen for:
[link-]
[link+]
link= without [], or with only one bracket, or with bracket & parenthesis or curly brace
Or any other unmatched pairs: [...[, for instance.
(Edited)
Photo of Ed Jones(XLIX)

Ed Jones(XLIX)

  • 22871 Posts
  • 27177 Reply Likes
I just get used to the quirk. As long as it it is sent in, in "Square Brackets" it comes out correct. I'm sure you know this. It does not convert within the submission process. If you send it in improperly it will not convert. I'm sure you know this too.

So is this an idea for rewriting the software?
To add a pink screen when links [link=] is incorrect?
I believe that they cannot do this simply, and it may be a complicated software patch, and as such it may be not a priority at this time.

My thoughts!
Cheers
:):)
Photo of Michelle

Michelle, Official Rep

  • 13225 Posts
  • 10576 Reply Likes
Hi bderoes and Ed -

I have alerted the applicable team of your findings and they should take a look shortly.  As soon as I have an update on the status I will share the information with you here.
(Edited)