Windows 10 does not recognize my Alesis Q49 anymore

  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
My Alesis Q49 use to work great with ignite air, but not anymore please help
Photo of islandfellow

islandfellow

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Bill R.

Bill R., Employee

  • 5693 Posts
  • 286 Reply Likes
Hello,

Thanks for the post. I’d like to help! Refer to this helpful article Troubleshooting Class Compliant USB Computer Peripherals to help troubleshoot you with your product. Try it out and let me know how it goes!
Photo of Robert Schleicher

Robert Schleicher

  • 13 Posts
  • 3 Reply Likes
This may or may not be relevant, but after going through a massive update of Windows 10 (I forget the update number, but it was something like 1079, of 1709??), Windows was no longer recognizing my iPhone, when connected via USB.

The iPhone USB driver seemed to be correct (in my case, Apple Mobile Device USB driver), but still the phone wasn't being "recognized" when plugged in.

After Googling the symptoms, I found a suggestion to go to the Windows 10 "apps" menu (used to be called programs), and look for the Apple Mobile Service app. It was present, so I did a re-install (basically by double-clicking on the app, and then selecting the "repair" check-box, instead of the "uninstall" check box. This caused the app to be re-installed, after which everything worked again.

If your computer has recently done this major Windows 10 update, the update process may have caused either driver issues, or, as in my case, issues with the service app.

What I'm not sure of is what the name of the service app would be in your case....

Just a suggestion, which may or may not be applicable.....
Photo of Bill R.

Bill R., Employee

  • 5693 Posts
  • 286 Reply Likes
Thanks for helping out!
Photo of Kavekini Tuivaga

Kavekini Tuivaga

  • 1 Post
  • 0 Reply Likes
I have the same problem as Islandfellow, my laptop wont recognize my Alesis Q49 midi controller, it recognizes everything else I plug in, it just says device descriptor request failed.
Photo of Bill R.

Bill R., Employee

  • 5693 Posts
  • 286 Reply Likes
Sorry you're having issues, Kavekini. 

This error that you're experiencing is a Windows-related error and not related to the Q49. Please refer to this post from HP's forum for advice on how to resolve this error you're experiencing. If you're still experiencing issues after going through those steps then you may need to contact a computer technician.