Strike Pro Editor doesn't work for MAC OS Catalina

  • 2
  • Problem
  • Updated 2 weeks ago
  • Acknowledged
I just bought Alesis Strike Pro SE edition and I'm not able to manipulate properly the edition of sounds and kits without the corresponding software editor and doing it on the module itself is either very limited (for instance, not possible to copy a preset as user kit for easy edition, navigation on multiple screens, not possibility to check velocity sounds, etc) counterproductive.

May you please provide the editor for MAC OS Catalina version?
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 2
Photo of Chaser

Chaser

  • 363 Posts
  • 66 Reply Likes
Community Home page..right column..there is a warning that's been posted for macOS 10.15 Catalina.

There are dozens upon dozens of developers who have the same issue.

You'll see a majority have a "Do not upgrade to macOS 10.15 Catalina until officially supported" warning.
Apple is requiring apps/drivers etc that are distributed outside of the ‌Mac App Store‌ to be notarized by Apple to run on ‌macOS Catalina‌ and macOS 10.15 Catalina no longer supports 32-bit software.
That means if you have a DAW, plug-in, virtual instrument or other apps that are only 32-bit, they will not work.

The STRIKE EDITOR is 32 bit..........
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes
I'm aware of that. However, is not because I've updated to macOS Catalina, because that is only applicable to people who already had a mac before the update. In my case, that's not my situation as I just bought a mac with Catalina already installed.
Photo of Chaser

Chaser

  • 363 Posts
  • 66 Reply Likes
Doesn't matter...update..or pre-installed...macOS Catalina doesn't support 32bit..
There isn't, nor has there ever been a 64 bit STRIKE Editor...Win or Mac.
If you wan't to be able to do everything you listed in your first post you may as well try to find another machine for the time being until Alesis develops a 64 bit version
Photo of DAVID

DAVID

  • 1 Post
  • 0 Reply Likes
It doesn't make since for me to have bought the Strike Special Edition kit and now I can't manipulate it with the Strike Editor software! Catalina has been out for a while now. Please fix this!! Thanks!!
Photo of Omar Rowe

Omar Rowe

  • 13 Posts
  • 1 Reply Like
One workaround is running windows on your mac through parallels or a virtual software that works until.
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes
Really? Who is gonna pay the Windows license? On the other hands, if I run on Mac, why I would be interested to install Windows? That’s no an option to me. Alesis shall provide the editor running on Mac with latest version of OS. Even when I can modify Kits, the problem is how to load my own sounds and build the instrument file require to build the Kits. So, very frustrating having invested +3,500$ CAD and find that I cannot even load my own samples or articulate properly the layers of sounds on kits.
Photo of Omar Rowe

Omar Rowe

  • 13 Posts
  • 1 Reply Like
Was just a suggestion buddy, this is what I found worked in my situation am in the same boat, but I hope they release something for the mass sooner rather than later.

Kind Regards,
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes
No problem. I understand. Thanks anyway!
Photo of Omar Rowe

Omar Rowe

  • 13 Posts
  • 1 Reply Like
Sure thing, other topic, have you had any triggering issue with you hi hats? or ride? I thought the se would be an upgrade but already bought a replacement hat
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes
Well.... how to say, I’m running the Strike Pro Spetial Edition with improved hihat and pads. I’ve changed all the default values of the triggers. I’ve also had to layered sounds to get better response. In general doesn’t work as my old Roland TD9v2KVX with VH-11, so still trying to get there but, I find my self limited due to the editor, because some of my issues might be a eventually fixed with more hihat dynamic. Are you also on SE edition?
Photo of Omar Rowe

Omar Rowe

  • 13 Posts
  • 1 Reply Like
Yes also on the SE, and am using the kit for live worship, we can't seem to get a great kit for live mix, so trying the vh10 hats this coming sunday, thought maybe getting SD3 might fix some issues, but feel hard pressed to put more money in, if issues aren't fixed soon might get one of the new Rolands, or drumtech
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes
Great. Please let me know how well the VH-10 works on it. I might follow the same path as you. Otherwise, I will replace the module by the TD30, but not sure if it would work at all.
On the other hands, have you also experienced the module getting frozen at certain point when playing with user kits? It happened to me at least 4 times already. Interface doesn't response at all, but still playing sounds when hitting the pads. Very annoying and disappointing.
Photo of Omar Rowe

Omar Rowe

  • 13 Posts
  • 1 Reply Like
Definitely, will Keep you posted here No freezing, tru a reset of the module ?
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes
I've just updated a song cover with the edrum here: https://youtu.be/uFTfE5NA2zo just for fun as I was able to fix the hi-hat issue
Photo of Chaser

Chaser

  • 363 Posts
  • 66 Reply Likes
STRIKE Editor version 1.1.3 has been released.

Change History Version 1.1.3 (March 24, 2020)
Support for macOS Catalina (version 10.15)

Note:This update is for macOS only

https://www.alesis.com/products/view2...
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes
GREAT NEWS!!!! Finally.
Photo of Omar Rowe

Omar Rowe

  • 13 Posts
  • 1 Reply Like
finally
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes
However it's not a fully functional editor....

When attempting to edit an instrument in the Editor, the dialog box supposedly to select what type of instrument to create, as indicated in Editor manual, doesn't appear and therefore you can't create a Hi-Hat Pedal or Hi-Hat Cymbal!

I'm again disappointed with this product when considering that I've invested almost 3K for a product that's still not delivery at its maximum capabilities due to the limited or unreleased necessary tools from Alesis.

See image below where it's indicated such dialog in the Editor Manual:

Then when you click on File/New option, it doesn't show such dialog and therefore doesn't allow the creation of HiHat Pedal/Cymbal instruments.


It only advises that your existing instrument will be lost and we you click ok, it remains in the window without even cleaning the instrument screen.
Photo of Chaser

Chaser

  • 363 Posts
  • 66 Reply Likes
The bottom pic shows your in Instrument mode, pedal..and a Factory/Preset sin file has been selected with the velocity ranges showing.
How did you get there if you didn't select it.
By default when the Editor starts it's in Kit Mode.
When you switch to Instrument Mode the Instrument mode starts with Single instrument and editing windows are empty not Hi hat pedal with a preset selected.
sin files don't automatically appear in the editing box with velocities ranges showing unless selected...if they do , then there may be a problem.

The "you will lose unsaved changes box" is automatic if you edited,didn't save as new instrument or leaving the window.
You cannot change samples/edit/overwrite/save Factory presets they are write protected..they will be saved as a new User instrument (sin) or Kit (skt) file.

When you click New to create a new instrument the warning box appears, if you don't want to save the current instrument click yes..after the warning box closes a new box should automatically open..with a drop down menu for selecting a single..HH cymbal...HH pedal.
Photo of Lionel Okfp

Lionel Okfp

  • 34 Posts
  • 0 Reply Likes
The only way to get Pedal or Cymbal HiHat is by selecting an existing instrument with such type. But is confusing because it already has samples selected. It’s suppose that when selecting New, it should ask the instrument type. That dialogue is not shown.