Alesis VI61 keyboard button mapping problem

  • 1
  • Problem
  • Updated 3 weeks ago
  • Acknowledged
I have a new Alesis VI61 keyboard and I am getting a weird result trying to map midi functions to Ableton. The VI61 has three rows of buttons, 1-16, 17,32 and 33-48. The top row works fine, press once blue light comes on the button and the track is armed, press again, light goes off arm is off, however rows 17-32 and 33-48 act differently, one press and record arm or solo activates with a blue light on the keyboard but it takes two or sometimes three presses to turn the DAW function off again. It only takes one mouse click to turn all these DAW functions on and off again.

Unless I program these buttons they do nothing in Ableton which is a bit weird as I thought the VI61 was fully supported.

I have checked the Alesis software and all buttons 1-48 are all programmed the same, they are on the same midi channel, and on is 127 and off is 0.

I contacted Ableton support, they told me to test the midi info using Bomed midi translator, I did this and all is fine. Any ideas.
Photo of lifeofbrian

lifeofbrian

  • 7 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 1
Photo of steven.j.caldwell

steven.j.caldwell

  • 5 Posts
  • 0 Reply Likes
HI, make sure all of your buttons are programmed as momentary. Of course this means you will not get status of the button state but the VI61 does not allow remote LED updates.

Steve Caldwell
Bome Q and A Moderator and
Independent Bome Consultant/Specialist
bome@sniz.biz
Photo of Matt Ferri

Matt Ferri, Employee

  • 210 Posts
  • 13 Reply Likes
Hello lifeofbrian,

Thank you for posting!

Steven is correct, make sure the buttons are set to momentary.

Hope that helps!