Alesis M1 Mk2 active monitors won't power on

  • 2
  • Problem
  • Updated 2 years ago
  • In Progress
Right m1 mk2 monitor won't power on. I thought it may be a dead fuse in power cable, so tried plugging in cable from other monitor, but no luck. I plugged the power cable back into the other monitor (left, working), now the left monitor won't power on either. please help!?
Photo of Corin Bornoff

Corin Bornoff

  • 1 Post
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Chris D

Chris D, Employee

  • 5182 Posts
  • 153 Reply Likes
Hello Corin,

Thanks for posting! I'd like to help! Sounds like you may need to service your speakers. Warranty and non-warranty claims are not handled here on the forum but I can point you in the right direction to help you out! Here are a couple of options that you could choose from:

• Submit a Warranty Claim or Service Inquiry with our Technical Support team by logging onto www.alesis.com/support. Select Warranty Claim or Service Inquiry from the drop down menu.

or

• For quicker support, call your nearest Support Office or International Distributor. If you’re going with your International Distributor, simply select your country to contact them.
Photo of E SERGIC

E SERGIC

  • 1 Post
  • 0 Reply Likes
Hi Corin,

I've just had the exact same problem, checked if it was the cable now both won't power on. Did you manage to find out what needed repairing?
Photo of James Neill

James Neill

  • 1 Post
  • 0 Reply Likes
I have opened up the back of mine having this issue and found a burnt out fuse at the power input connector. Replaced but still having an issue of no power getting through